Calibre and Qt 5.5

A recent apt-get dist-upgrade resulted in the removal of calibre and calibre-bin from my system. I’ve been using Calibre to convert e-books from HTML and EPUB (some developer references, some fanfiction =) ) and copy them onto my Kindle.

It turned out that the Calibre packaged in Ubuntu required qtbase-abi-5-4-2 and my recent dist-upgrade installed Qt 5.5. I needed to upgrade to Calibre 2.49, which wasn’t available on any of the PPAs I checked (despite instructions to the contrary).

Installing Calibre from the Calibre website made it work, though. In fact, the Calibre website says:

Please do not use your distribution provided calibre package, as those are often buggy/outdated. Instead use the Binary install described below.

I wasn’t too keen on piping the output of a wget command to sudo , but a quick scan of the script didn’t turn up anything suspicious. Anyway, now I can convert EPUBs to MOBIs and easily copy them onto my Kindle, yay!